GlobalAdmin is developed only for lastest versions of modern browsers (Chrome, Firefox). Deprecated browsers is unsupported and will never be supported.